verschwoerhaus wiki


DIESE SEITE IST NOCH UNFERTIG UND IN DER ERSTEN BEARBEITUNG!


MikroTik LtAP LR8 LTE kit

ID: RBLtAP-2HnD & R11e-LTE & LoRa8 oder LR8

Links/Quellen:

Konfiguration

Zugriff über Webinterface (https://192.168.88.1), alternativ Winbox tool (https://mt.lv/winbox) oder natürlich mit Kommandozeile über die Serielle Schnittstelle oder SSH (user/login: admin / Password ist in den Werkseinstellungen leer).

Update und extra Pakete installieren

  • Router anschmeißen, im Webinterface Quick Set = Home AP setzen.
  • Am besten erst dann Router per LAN inkl. DHCP anstöpseln, so dass er online gehen kann.
  • RouterOS Updaten:
/system package update check-for-updates
/system package update download
/system reboot
  • Extra Pakete herunterladen: all_packages-mmips-6.49.2.zip
  • Paket für LoRaWAN-Karte (lora-6.49.2-mmips.npk) entpacken und auf den Router laden; z.B. Upload über Webinterface (unter Files).
  • Zur Installtion neustarten: im Webinterface WebFig > System > Reboot oder /system reboot.
  • Zur Kontrolle mal einen Blick auf die vorhandenen Pakete und deren Versionen werfen (Versionsstand dieser Anleitung ist 6.49.2), das sollte dann so aussehen:
[maint@MikroTik] > /system package print 
Flags: X - disabled 
 #   NAME                                                                   VERSION                                                                   SCHEDULED              
 0   routeros-mmips                                                         6.49.2                                                                                           
 1   system                                                                 6.49.2                                                                                           
 2 X ipv6                                                                   6.49.2                                                                                           
 3   wireless                                                               6.49.2                                                                                           
 4   hotspot                                                                6.49.2                                                                                           
 5   mpls                                                                   6.49.2                                                                                           
 6   routing                                                                6.49.2                                                                                           
 7   ppp                                                                    6.49.2                                                                                           
 8   dhcp                                                                   6.49.2                                                                                           
 9   security                                                               6.49.2                                                                                           
10   advanced-tools                                                         6.49.2                                                                                           
11   gps                                                                    6.49.2                                                                                           
12   lora                                                                   6.49.2

GPS einrichten

/system gps set enable=yes
/system gps print
/system gps monitor

Wenn vorhanden externe Antenne anschließen (an der hinteren/unteren SMA-Buchse) und auf diese Antenne umschalten:

/system gps set gps-antenna-select=external

LoRaWAN-Gateway aufsetzen

… für ein LoRaWAN-Gateway, das die Pakete ins The Things Network schickt. Hier eine knappe Zusammenfassung, mehr Infos und Bilder gibt's z.B. in der Anleitung für den alten The Things Stack v2 und den verwandten Router MikroTik Routerboard wAP wAP LoRa8.

  • Externe Antenne anschließen! An vordere/obere SMA-Buchse.
  • /lora export
    • prüfen, ob der gewünschte Server unter /lora servers schon konfiguriert ist, also ob z.B. der Eintrag name=“TTN V3 (eu1)” mit address=eu1.cloud.thethings.network existiert.
  • /lora print
    • channel-plan sollte für die EU z.B. eu-868 sein, sonst korrigieren.
    • gatway-id kopieren/merken.
  • Mit der Gateway-ID ein Gateway in der Console des The Things Network anlegen.
    • Gateways > + Add Gateway > aktuell (2022-02-11) funktionieren die Standardeinstellungen, es müssen also nur die folgenden Werte eingegeben werden:
      • Gateway ID: von dir gewählte Bezeichnung für's Gateway (nur Buchstaben und -; zwischen 2 und 36 Zeichen; muss weltweit einzigartig sein), für
      • Gateway EUI: s.o., gateway-id aus dem MikroTik-Router.
      • Frequency Plan: i.d.R. Europe 868-870 MHz (SF9 for RX2 - recommended).
      • ggf. Owner auf verschwoerhaus anpassen ;-)
    • Bei Unklarheiten hilft vielleicht ein Blick in die Anleitung von MikroTik hier.
  • MikroTik-Router fertig konfigurieren:
/system routerboard usb set type=mini-PCIe
/lora print
/lora set 0 servers="TTN V3 (eu1)"
/lora enable 0
/lora print

Zum Test auf Traffic warten:

  • Im Webinterface des MikroTik unter WebFig > LoRa > Traffic (gibt's das wirklich nicht auf der Kommandozeile?!)…
  • Und/oder in der Console des TheThingsNetwork beim neu erstellten Gateway.

evtl.: SIM-Karte installieren und Internetzugang über Mobilfunkverbindung einrichten

Hilfeseiten:

Folgende Konfiguration hat mit einer O2-Festnetz-SIM-Karte funktioniert:

  • TODO
  • /system reboot
  • Check der Mobilfunkverbindung mit /interface lte info lte1 sollte bspw. so aussehen:
TODO

Tipps und Tricks

Debugging, informative Kommandos

Mobilfunk

Verbindung/Status checken:

/interface lte info lte1 once
/interface lte info lte1

SMS-Versenden? https://wiki.mikrotik.com/wiki/Manual:Tools/Sms

Konfig-Dumps

[maint@MikroTik] > /system resource print
                   uptime: 19m7s
                  version: 6.49.2 (stable)
               build-time: Dec/03/2021 14:53:53
         factory-software: 6.44.6
              free-memory: 85.3MiB
             total-memory: 128.0MiB
                      cpu: MIPS 1004Kc V2.15
                cpu-count: 4
            cpu-frequency: 880MHz
                 cpu-load: 0%
           free-hdd-space: 4828.0KiB
          total-hdd-space: 16.3MiB
  write-sect-since-reboot: 110
         write-sect-total: 2242
               bad-blocks: 0%
        architecture-name: mmips
               board-name: LtAP LTE kit
                 platform: MikroTik
The following default configuration has been installed on your router:

Welcome to RouterOS!
   1) Set a strong router password in the System > Users menu
   2) Upgrade the software in the System > Packages menu
   3) Enable firewall on untrusted networks
   4) Set your country name to observe wireless regulations
-----------------------------------------------------------------------------
LTE CPE Router with wireless AP:
 * lte interface connected to providers network (WAN port);
 * WAN port is protected by firewall and enabled DHCP client
LAN Configuration:
    IP address 192.168.88.1/24 is set on bridge (LAN port)
    DHCP Server: enabled;
    DNS: enabled;
wlan1 Configuration:
    mode:                ap-bridge;
    band:                2ghz-b/g/n;
    tx-chains:           0;1;
    rx-chains:           0;1;
    installation:        outdoor;
    wpa2:      no;
    ht-extension:        20/40mhz-XX;
WAN (gateway) Configuration:
    gateway:  lte1 ;
    ip4 firewall:  enabled;
    NAT:   enabled;